summary refs log tree commit diff
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2023-06-14 09:48:49 -0300
committerLudovic Courtès <ludo@gnu.org>2023-07-07 15:30:22 +0200
commit045361dd057e1836f7dae952a0f7ba983cff2d5a (patch)
tree2c7b17f277de29511c56451c15cc998de4f3c124
parentf0c5f6eda17cdd24c571e26c359bbab026068d35 (diff)
downloadguix-045361dd057e1836f7dae952a0f7ba983cff2d5a.tar.gz
gnu: Add ghc-sdl2-gfx.
* gnu/packages/haskell-xyz.scm (ghc-sdl2-gfx): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 19af57c2d1..10a52c0586 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10444,6 +10444,27 @@ programming.")
 library.")
     (license license:bsd-3)))
 
+(define-public ghc-sdl2-gfx
+  (package
+    (name "ghc-sdl2-gfx")
+    (version "0.3.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "sdl2-gfx" version))
+              (sha256
+               (base32
+                "0r9m54ffkp1dv2ffz9i9318qhvpinc76iih7vg1dwq3siwgpxaxw"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "sdl2-gfx")))
+    (inputs (list ghc-lifted-base ghc-monad-control ghc-sdl2 ghc-vector sdl2-gfx))
+    (native-inputs (list pkg-config))
+    (home-page "http://hackage.haskell.org/package/sdl2-gfx")
+    (synopsis "Haskell bindings to SDL2_gfx")
+    (description
+     "This package provides Haskell bindings to the SDL2_gfx graphics
+library.")
+    (license license:expat)))
+
 (define-public ghc-sdl-image
   (package
     (name "ghc-sdl-image")