summary refs log tree commit diff
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-04-27 18:58:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-04-29 00:29:41 +0200
commit0d570b60195e8db89cfa026f09e84a933a636e7d (patch)
tree3d404e5dae9550305c6fd9aed0235eb1cec55009
parent43684b19da6cc6c0a046214210d060aa77ede6b1 (diff)
downloadguix-0d570b60195e8db89cfa026f09e84a933a636e7d.tar.gz
gnu: emacs-hyperbole: Install images and help files.
* gnu/packages/emacs-xyz.scm (emacs-hyperbole)[arguments]: Include help file
and install images for the manual.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 758336a0b1..ef26d19506 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -359,6 +359,7 @@ server}.  The main advantage compared to @code{vc-hg} is speed.")
      `(#:include '("DEMO"
                    "DEMO-ROLO.otl"
                    "HY-ABOUT"
+                   "man/hkey-help.txt"
                    "\\.el$"
                    "\\.info$"
                    "\\.kotl$")
@@ -373,8 +374,15 @@ server}.  The main advantage compared to @code{vc-hg} is speed.")
                 (string-append (assoc-ref inputs "inetutils")
                                "/bin/dnsdomainname")))
              (substitute* "hyperbole.el"
-               (("\\(hyperb:check-dir-user\\)") ""))
-             #t)))))
+               (("\\(hyperb:check-dir-user\\)") ""))))
+         (add-after 'install 'install-images
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (for-each (lambda (file)
+                           (install-file
+                            file
+                            (string-append out "/share/info/im")))
+                         (find-files "man/im" "\\.png$"))))))))
     (inputs
      `(("inetutils" ,inetutils)))
     (home-page "https://www.gnu.org/software/hyperbole/")