summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-10 21:39:25 +0200
committerMarius Bakke <marius@gnu.org>2022-08-11 00:21:11 +0200
commit178b762d686405a25dcc7bbf2f4dda98df8a3bde (patch)
treef24464530500bdcf0a6ceb78938bad94abefda89
parentce0aa88d1cfe663fa3d64814a3d14b64219cbefe (diff)
downloadguix-178b762d686405a25dcc7bbf2f4dda98df8a3bde.tar.gz
gnu: libetonyek: Don't hard code mdds version.
* gnu/packages/libreoffice.scm (libetonyek)[arguments]: Automatically pass the
major+minor version components of the "mdds" input.
-rw-r--r--gnu/packages/libreoffice.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 895acdb572..da30575357 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -34,6 +34,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module (guix build-system trivial)
+  #:use-module (guix gexp)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
@@ -444,7 +445,11 @@ CorelDRAW documents of all versions.")
                "16hy60ws29pb4pz3z5l4920yn9hnk2vlij0xfs5qi1w4drd46c5l"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags '("--with-mdds=1.5")))
+     (list #:configure-flags
+           #~(list (string-append "--with-mdds="
+                                  #$(version-major+minor
+                                     (package-version
+                                      (this-package-input "mdds")))))))
     (native-inputs
      (list cppunit doxygen gperf pkg-config))
     (propagated-inputs ; in Requires or Requires.private field of .pkg