summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-25 16:08:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-25 16:17:49 +0200
commit1fca85cd8807b0c3a79b7f597136348a5a177944 (patch)
tree1a1ac3a472d6cd5879cc17668e42553c20705918
parentf69f346289ca8bbdc9ce6afa35b29fe8f8e092d5 (diff)
downloadguix-1fca85cd8807b0c3a79b7f597136348a5a177944.tar.gz
gnu: ivar: Update to 1.4.2.
* gnu/packages/bioinformatics.scm (ivar): Update to 1.4.2.
[arguments]: Remove -Werror flag.
-rw-r--r--gnu/packages/bioinformatics.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 042250e46b..c69380b5c8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17814,7 +17814,7 @@ compute communities on graphs weighted or unweighted.")
 (define-public ivar
   (package
     (name "ivar")
-    (version "1.3.1")
+    (version "1.4.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -17823,9 +17823,18 @@ compute communities on graphs weighted or unweighted.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "044xa0hm3b8fga64csrdx05ih8w7kwmvcdrdrhkg8j11ml4bi4xv"))))
+                "0v3rsak84ilg4iaynwpmmkj507vham5rjk2pfsmylpaqylgc69yx"))))
     (build-system gnu-build-system)
-    (arguments `(#:parallel-tests? #false)) ; not supported
+    (arguments
+     (list
+      #:parallel-tests? #false          ;not supported
+      #:phases
+      '(modify-phases %standard-phases
+         (add-after 'unpack 'patch-CXXFLAGS
+           (lambda _
+             (substitute* '("src/Makefile.am"
+                            "tests/Makefile.am")
+               (("-Werror") "")))))))
     (inputs
      (list htslib zlib))
     (native-inputs