summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-22 16:25:56 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:47 -0500
commit21ce20bd2f31a016a7f777c165e9ac11848e5f0b (patch)
tree1b33e833f9d45ed52d3a81f2883cde18fa4597c4
parent3c0b3733104e0a5846138ed7ee25e0c15cfcb28d (diff)
downloadguix-21ce20bd2f31a016a7f777c165e9ac11848e5f0b.tar.gz
gnu: python-scanpy: Do not set PYTHONPATH.
* gnu/packages/bioinformatics.scm (python-scanpy)[phases]
{check}: Do not set PYTHONPATH.
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9bc2bb85e8..f3cdcc4a20 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12924,11 +12924,7 @@ in RNA-seq data.")
              (delete-file "scanpy/tests/test_preprocessing.py")
              (delete-file "scanpy/tests/test_read_10x.py")
 
-             (setenv "PYTHONPATH"
-                     (string-append (getcwd) ":"
-                                    (getenv "PYTHONPATH")))
-             (invoke "pytest")
-             #t)))))
+             (invoke "pytest"))))))
     (propagated-inputs
      `(("python-anndata" ,python-anndata)
        ("python-h5py" ,python-h5py)