summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-05-27 21:06:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-31 10:18:29 +0200
commit265ee14650d0207299a8dac0b857b6412f86e0c7 (patch)
treecfb5e9e73bab928384b4a9e9f26f3c8e833ddaf8
parent8ae48674ce3493fddfdc0d2acead285396ed1da0 (diff)
downloadguix-265ee14650d0207299a8dac0b857b6412f86e0c7.tar.gz
gnu: emacs-exec-path-from-shell: Update to 1.12.
* gnu/packages/emacs-xyz.scm (emacs-exec-path-from-shell): Update to 1.12.
[source]: Use git-fetch.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1b0e623bbd..2c56a7cbfc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9277,16 +9277,16 @@ functionality is inherited from @code{hcl-mode}.")
 (define-public emacs-exec-path-from-shell
   (package
     (name "emacs-exec-path-from-shell")
-    (version "1.11")
+    (version "1.12")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://stable.melpa.org/packages/exec-path-from-shell-"
-             version ".el"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/purcell/exec-path-from-shell")
+             (commit version)))
        (sha256
         (base32
-         "03qjgb81cq1l3j54lvlf98r75vmmgd06mj6qh5wa6mz4xzp4w26r"))))
+         "1ga8bpxngd3ph2hdiik92c612ki71qxw818i6rgx6f6a5r0sbf3p"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/purcell/exec-path-from-shell")
     (synopsis "Get environment variables such as @var{PATH} from the shell")