summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-13 15:16:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-13 18:26:25 +0200
commit270db2a56bc50bcab5739de2c9393644ab65ac6c (patch)
treec2c1b483f4e5466104650761805dbdcb530b0d9e
parent18d6173214eb82781b36d041bab99494c653f979 (diff)
downloadguix-270db2a56bc50bcab5739de2c9393644ab65ac6c.tar.gz
gnu: Add xuidesigner.
* gnu/packages/music.scm (xuidesigner): New variable.
-rw-r--r--gnu/packages/music.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 446580dc52..a8e01b8dba 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6176,6 +6176,42 @@ audio and MIDI plugins that can also run as standalone JACK applications.")
     (home-page "https://x42-plugins.com/x42/")
     (license license:gpl2+)))
 
+(define-public xuidesigner
+  (package
+    (name "xuidesigner")
+    (version "0.9")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/brummer10/XUiDesigner")
+                    (commit (string-append "v" version))
+                    ;; For libxputty
+                    (recursive? #true)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "1ap6g2j9lr4x9gpnavdhs4qa3z4dw100xgknpi6ysj0rmzc220mi"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f                       ;no "check" target
+      #:make-flags
+      #~(list (string-append "PREFIX=" #$output)
+              (string-append "CC=" #$(cc-for-target)))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure))))
+    (inputs
+     (list cairo libx11 lilv))
+    (native-inputs
+     (list pkg-config which xxd))
+    (home-page "https://github.com/brummer10/XUiDesigner")
+    (synopsis "GUI generator tool to create X11 UIs for LV2 plugins")
+    (description "XUiDesigner parses an LV2 plugin's ttl file and generates
+the needed controller widgets.  The created GUI can be saved as UI-Bundle,
+which then could be built and installed.  For later editing of the UI, a JSON
+file is added, which you could load per drag 'n drop into XUiDesigner.")
+    (license license:bsd-0)))
+
 (define-public zam-plugins
   (package
     (name "zam-plugins")