summary refs log tree commit diff
diff options
context:
space:
mode:
authorconses <contact@conses.eu>2023-02-20 20:58:46 +0100
committerLudovic Courtès <ludo@gnu.org>2023-02-25 00:00:33 +0100
commit3164d48e55b2d614bcd8def064d4671578617963 (patch)
tree5623efa5a5d1ca2866efa7c1f6e604222069c987
parentd00c2e9c2b75bc2c259947a56d1245d50d000e68 (diff)
downloadguix-3164d48e55b2d614bcd8def064d4671578617963.tar.gz
gnu: Add postmarketos-theme.
* gnu/packages/gnome-xyz.scm (postmarketos-theme): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index f25cf446d7..74b676c484 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1436,6 +1436,30 @@ variants.")
                    license:lgpl2.1         ; Some style sheets.
                    license:cc-by-sa4.0)))) ; Some icons
 
+(define-public postmarketos-theme
+  (package
+    (name "postmarketos-theme")
+    (version "0.6.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/postmarketOS/postmarketos-theme")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "09in7737cirmw2c0ac40ac29szfgdva6q0zl32mdi12marybd2g5"))))
+    (build-system meson-build-system)
+    (native-inputs (list sassc))
+    (home-page "https://gitlab.com/postmarketOS/postmarketos-theme")
+    (synopsis "PostmarketOS themed themes")
+    (description
+     "@code{postmarketos-theme} contains a GTK3 and GTK4 theme which is based
+on Adwaita but replaces the standard blue highlights in the theme with
+postmarketOS green.  There's also the oled and paper variants of the theme
+that are completely black and completely white.")
+    (license license:lgpl2.0+)))
+
 (define-public eiciel
   (package
     (name "eiciel")