summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-09 16:49:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:22 +0300
commit3339fba500be2a611b5cf7420be8a4e683e70c28 (patch)
treeef5e7773c68026c19f1a086221eaeb10b1f508eb
parenta54ba2322ec5902f72b947d4aa8197b1c8152c7a (diff)
downloadguix-3339fba500be2a611b5cf7420be8a4e683e70c28.tar.gz
gnu: Add rust-option-set-0.1.
* gnu/packages/crates-io.scm (rust-option-set-0.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 150ed2f80c..7141cab09a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39828,6 +39828,31 @@ system for OpenSSL.")
     (description "This package provides an OPML parser for Rust.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-option-set-0.1
+  (package
+    (name "rust-option-set")
+    (version "0.1.4")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "option-set" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32 "16wsxh2qmjb2bf7mcq7dhlpzwkslzgjpg3nwzx97ia6gpnb2sfy8"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-heck" ,rust-heck-0.3)
+        ("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs
+       (("rust-bitflags" ,rust-bitflags-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-serde-yaml" ,rust-serde-yaml-0.8))))
+    (home-page "https://github.com/H2CO3/option_set.git")
+    (synopsis "Bitflags on steroids")
+    (description "This package provides an extended version of rust bitflags.")
+    (license license:expat)))
+
 (define-public rust-ord-subset-3
   (package
     (name "rust-ord-subset")