summary refs log tree commit diff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-02-18 13:39:22 +0100
committerLars-Dominik Braun <lars@6xq.net>2022-02-21 10:41:25 +0100
commit516c9f486978d76f0c6f3365bbda1c622a542a69 (patch)
tree6ff7ef2543a5101acfd0c71efc20508f0deeb84e
parent6cae4e97927dd215bc5af84e7c4d938a26fb40c1 (diff)
downloadguix-516c9f486978d76f0c6f3365bbda1c622a542a69.tar.gz
gnu: Add r-rlrsim.
* gnu/packages/statistics.scm (r-rlrsim): New variable.
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 648462be03..1351ed7713 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -6939,3 +6939,26 @@ is used to allow menus, dialogs, and the response to mouse actions to be
  customized.")
       (home-page "http://homepage.divms.uiowa.edu/~luke/xls/xlsinfo/")
       (license license:expat))))
+
+(define-public r-rlrsim
+  (package
+    (name "r-rlrsim")
+    (version "3.1-6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "RLRsim" version))
+        (sha256
+          (base32 "1wkkibr250frsbfq70m9jdrylxb492zibf5w03z6zis98pjffssp"))))
+    (properties `((upstream-name . "RLRsim")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-lme4 r-mgcv r-nlme r-rcpp))
+    (home-page "https://github.com/fabian-s/RLRsim")
+    (synopsis
+      "Exact (Restricted) Likelihood Ratio Tests for Mixed and Additive Models")
+    (description
+      "Rapid, simulation-based exact (restricted) likelihood ratio tests for testing
+the presence of variance components/nonparametric terms for models fit with
+@code{nlme::lme()}, @code{lme4::lmer()}, @code{lmeTest::lmer()},
+@code{gamm4::gamm4()}, @code{mgcv::gamm()} and @code{SemiPar::spm()}.")
+    (license (list license:gpl2+ license:gpl3+))))