summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-24 19:22:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-24 19:49:04 +0200
commit523e5ee2f1c29267f55839d273687e2fd20475d8 (patch)
tree5da495571db9573328dc87f9ccfb8309ab81a634
parent9703ecc47bfc2324669f9950b21bcca2b99b4c89 (diff)
downloadguix-523e5ee2f1c29267f55839d273687e2fd20475d8.tar.gz
gnu: Add python-rich-click.
* gnu/packages/python-xyz.scm (python-rich-click): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0e4cb8fd20..d514f2117f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16816,6 +16816,29 @@ is made as zipfile like as possible.")
 syntax highlighting, markdown and more to the terminal.")
     (license license:expat)))
 
+(define-public python-rich-click
+  (package
+    (name "python-rich-click")
+    (version "1.6.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "rich-click" version))
+              (sha256
+               (base32
+                "0zkp2sn0vz1hhjbv9bf8fifyzi8ib2d7v7sfak8n3qn67rlrdzzq"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-click python-importlib-metadata python-rich))
+    (native-inputs (list python-pre-commit))
+    (home-page "https://github.com/ewels/rich-click")
+    (synopsis "Format click help output nicely with rich")
+    (description "Click is a \"Python package for creating beautiful command
+line interfaces\".  Rich is a \"Python library for rich text and beautiful
+formatting in the terminal\".  The intention of rich-click is to provide
+attractive help output from click, formatted with rich, with minimal
+customization required.")
+    (license license:expat)))
+
 (define-public python-textual
   (package
     (name "python-textual")