summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-04-28 11:32:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-28 11:43:34 +0300
commit562c3a4e12b305bb549ed920d0954d9018f158eb (patch)
tree50640e514e50815a51e998aaed187fd259fce42f
parentd027637026f8aedabe5a0ceeb2c74d1d77d0109b (diff)
downloadguix-562c3a4e12b305bb549ed920d0954d9018f158eb.tar.gz
gnu: keepassxc: Wrap binary with wrap-qt-program.
* gnu/packages/password-utils.scm (keepassxc)[arguments]: Import
qt-utils module. Replace custom 'wrap-bin phase with 'wrap-qt phase.
-rw-r--r--gnu/packages/password-utils.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index d7942a0f8b..ef091fd126 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2016 Jessica Tallon <tsyesika@tsyesika.se>
@@ -136,19 +136,18 @@ human.")
         (base32 "0azq20rqsx7axrigha4qh81ipvhqnnlb27w3xdjg5z4h3jky4dp5"))))
     (build-system cmake-build-system)
     (arguments
-     '(#:configure-flags '("-DWITH_XC_ALL=YES"
+     `(#:modules ((guix build cmake-build-system)
+                  (guix build qt-utils)
+                  (guix build utils))
+       #:imported-modules (,@%cmake-build-system-modules
+                            (guix build qt-utils))
+       #:configure-flags '("-DWITH_XC_ALL=YES"
                            "-DWITH_XC_UPDATECHECK=NO")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'install 'wrap-bin
-           (lambda* (#:key outputs inputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (wrap-program (string-append out "/bin/keepassxc")
-                 `("QT_PLUGIN_PATH" ":" prefix
-                   ,(map (lambda (label)
-                           (string-append (assoc-ref inputs label)
-                                          "/lib/qt5/plugins"))
-                         '("qtbase" "qtsvg")))))
+         (add-after 'install 'wrap-qt
+           (lambda* (#:key outputs #:allow-other-keys)
+             (wrap-qt-program (assoc-ref outputs "out") "keepassxc")
              #t)))))
     (native-inputs
      `(("asciidoctor" ,ruby-asciidoctor)