summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-08 16:45:48 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-08 22:36:34 +0200
commit590074a74973277599e848b59ad4089169d3a125 (patch)
tree2e5b950421df0a971693631552408a1fac6366c8
parent71dc19d9cba0c8d03540ab62cf5390442c0f8948 (diff)
downloadguix-590074a74973277599e848b59ad4089169d3a125.tar.gz
gnu: python-cachelib: Update to 0.4.1.
* gnu/packages/python-xyz.scm (python-cachelib): Update to 0.4.1.
[arguments]: Enable tests.
[native-inputs]: Add python-pytest and python-pytest-xprocess.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6cf42f1109..dfa2bb090c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11157,16 +11157,25 @@ signature of a file or buffer.")
 (define-public python-cachelib
   (package
     (name "python-cachelib")
-    (version "0.1.1")
+    (version "0.4.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "cachelib" version))
        (sha256
-        (base32 "0vs7nimlbhqy9kjcc90nswkhs3kgl28ag19jssx9qwlcsrkmmsa7"))))
+        (base32 "0p4chkvbvffcllsny5rpzmsq2vyr24ql3kzif4ha0fxp3fp7vqk8"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f)) ;no tests
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "pytest")))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-xprocess" ,python-pytest-xprocess)))
     (home-page "https://github.com/pallets/cachelib")
     (synopsis "Collection of cache libraries")
     (description "Cachelib is a library extracted from @code{werkzeug} which