summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-06 18:09:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-06 18:26:02 +0200
commit5bef0f108c3883bbe8888c749d7e6e2a0db61fc4 (patch)
treed6724a0eef2a768795c7348e9beb9424f4131bfb
parent834b8a4110758bec27753976ec0fe77cd4c32e30 (diff)
downloadguix-5bef0f108c3883bbe8888c749d7e6e2a0db61fc4.tar.gz
gnu: python-olefile: Update to 0.46.
* gnu/packages/python-xyz.scm (python-olefile): Update to 0.46.
[source]: Switch to release tarball instead of git snapshot.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b911d3693d..c37122f950 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4302,19 +4302,18 @@ services for your Python modules and applications.")
 (define-public python-olefile
   (package
     (name "python-olefile")
-    (version "0.45.1")
+    (version "0.46")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://github.com/decalage2/olefile/archive/v"
-                           version ".tar.gz"))
+       (uri (string-append "https://github.com/decalage2/olefile/releases/"
+                           "download/v" version "/olefile-" version ".tar.gz"))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "18ai19zwagm6nli14k8bii31ipbab2rp7plrvsm6gmfql551a8ai"))))
+         "1kjxh4gr651hpqkjfv89cfzr40hyvf3vjlda7mifiail83j7j07m"))))
     (build-system python-build-system)
-    (home-page
-     "https://www.decalage.info/python/olefileio")
+    (home-page "https://www.decalage.info/python/olefileio")
     (synopsis "Read and write Microsoft OLE2 files.")
     (description
      "@code{olefile} can parse, read and write Microsoft OLE2 files (Structured