summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-06 13:34:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-07 17:59:00 +0200
commit5d9d9383ac709608f5b1cebd05ddca5fbc3c7917 (patch)
tree4b4c6faee41ada2920107ae3f37522ad9af54b47
parent1e96e6ac8bc0285cc2adfac4ac29b538b84d5dfc (diff)
downloadguix-5d9d9383ac709608f5b1cebd05ddca5fbc3c7917.tar.gz
gnu: python-coveralls: Update to 1.11.1.
* gnu/packages/python-check.scm (python-coveralls): Update to 1.11.1.
[source]: Change to GIT-FETCH.
[arguments]: New field.
[propagated-inputs]: Remove PYTHON-SH and PYTHON-URLLIB3.
-rw-r--r--gnu/packages/python-check.scm30
1 files changed, 22 insertions, 8 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 70a5b1e452..22b9ea8df5 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -37,26 +38,39 @@
 (define-public python-coveralls
   (package
     (name "python-coveralls")
-    (version "1.6.0")
+    (version "1.11.1")
+    (home-page "https://github.com/coveralls-clients/coveralls-python")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "coveralls" version))
+       ;; The PyPI release lacks tests, so we pull from git instead.
+       (method git-fetch)
+       (uri (git-reference (url home-page) (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "1dswhd2q2412wrldi97hdwlsymj9pm79v7pvjx53z5wh2d33w8bg"))))
+         "1zr1lqdjcfwj6wcx2449mzzjq8bbhwnqcm5vdif5s8hlz35bjxkp"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (add-before 'check 'disable-git-test
+                    (lambda _
+                      ;; Remove test that requires 'git' and the full checkout.
+                      (delete-file "tests/git_test.py")
+                      #t))
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (if tests?
+                          (invoke "pytest" "-vv")
+                          (format #t "test suite not run~%"))
+                      #t)))))
     (propagated-inputs
      `(("python-coverage" ,python-coverage)
        ("python-docopt" ,python-docopt)
        ("python-pyyaml" ,python-pyyaml)
-       ("python-requests" ,python-requests)
-       ("python-sh" ,python-sh)
-       ("python-urllib3" ,python-urllib3)))
+       ("python-requests" ,python-requests)))
     (native-inputs
      `(("python-mock" ,python-mock)
        ("python-pytest" ,python-pytest)))
-    (home-page "https://github.com/coveralls-clients/coveralls-python")
     (synopsis "Show coverage stats online via coveralls.io")
     (description
      "Coveralls.io is a service for publishing code coverage statistics online.