summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-12-04 22:04:44 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-12-04 22:07:26 +0100
commit634b46a469cbb78e80419f047605c05930e7ff10 (patch)
tree88b78dd3b5b25bcbc8ceb9e3ef1e3d3e884a1704
parentba5cb6456de2d7f9d113dff6343f9374e9d086fb (diff)
downloadguix-634b46a469cbb78e80419f047605c05930e7ff10.tar.gz
gnu: java-commons-math3: Remove references to %build-inputs.
* gnu/packages/java.scm (java-commons-math3)[arguments]: Use a gexp
to remove references to %build-inputs.
-rw-r--r--gnu/packages/java.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 6a6ce4da42..2ec54cdd33 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -5901,12 +5901,12 @@ overly clever.")
      `(#:build-target "jar"
        #:test-target "test"
        #:make-flags
-       (let ((hamcrest (assoc-ref %build-inputs "java-hamcrest-core"))
-             (junit    (assoc-ref %build-inputs "java-junit")))
-         (list (string-append "-Djunit.jar="
-                              (car (find-files junit "jar$")))
-               (string-append "-Dhamcrest.jar="
-                              (car (find-files hamcrest ".*.jar$")))))
+       ,#~(let ((hamcrest #$(this-package-native-input "java-hamcrest-core"))
+                (junit    #$(this-package-native-input "java-junit")))
+            (list (string-append "-Djunit.jar="
+                                 (car (find-files junit "jar$")))
+                  (string-append "-Dhamcrest.jar="
+                                 (car (find-files hamcrest ".*.jar$")))))
        #:phases
        (modify-phases %standard-phases
          ;; We want to build the jar in the build phase and run the tests