summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-12 12:24:57 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 17:03:56 +0200
commit65302a7045832dfb99d3045788344b531298a8d5 (patch)
treef3977a997c34d947c37b2844fdbe04bee7df0944
parent3533db28ced3034898c4a1c58c4a8a50e35228a7 (diff)
downloadguix-65302a7045832dfb99d3045788344b531298a8d5.tar.gz
gnu: Deprecate the 'python-pytest-6' variable.
* gnu/packages/check.scm (python-pytest-6): Deprecate.
* gnu/packages/matrix.scm (python-matrix-nio)[native-inputs]: Change from
PYTHON-PYTEST-6 to PYTHON-PYTEST.
* gnu/packages/music.scm (beets)[native-inputs]: Likewise.
* gnu/packages/python-xyz.scm (python-munkres, python-cons)[native-inputs]: Likewise.
-rw-r--r--gnu/packages/check.scm3
-rw-r--r--gnu/packages/matrix.scm2
-rw-r--r--gnu/packages/music.scm2
-rw-r--r--gnu/packages/python-xyz.scm4
4 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b767be6552..0bce93fc79 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1028,7 +1028,8 @@ and functions, detailed info on failing assert statements, modular fixtures,
 and many external plugins.")
     (license license:expat)))
 
-(define-public python-pytest-6 python-pytest)
+(define-deprecated python-pytest-6 python-pytest)
+(export python-pytest-6)
 
 (define-public python-pytest-bootstrap
   (package
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 6604226f47..fc62041685 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -185,7 +185,7 @@ homeserver and generally help bootstrap the ecosystem.")
                         "not test_upload_binary_file_object "
                         "and not test_connect_wrapper"))))))))
     (native-inputs
-     `(("python-pytest" ,python-pytest-6)
+     `(("python-pytest" ,python-pytest)
        ("python-hyperframe" ,python-hyperframe)
        ("python-hypothesis" ,python-hypothesis)
        ("python-hpack" ,python-hpack)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index fe62c072c5..17010e6e82 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3762,7 +3762,7 @@ websites such as Libre.fm.")
            python-flask
            python-mock
            python-py7zr
-           python-pytest-6
+           python-pytest
            python-responses))
     (inputs
      (list bash-minimal
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fe344123f4..a8961f63fe 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15629,7 +15629,7 @@ way.")
                (base32
                 "00yvj8bxmhhhhd74v7j0x673is7vizmxwgb3dd5xmnkr74ybyi7w"))))
     (build-system python-build-system)
-    (native-inputs (list python-pytest-6))
+    (native-inputs (list python-pytest))
     (home-page "https://software.clapper.org/munkres/")
     (synopsis "Implementation of the Munkres algorithm")
     (description "The Munkres module provides an implementation of the Munkres
@@ -28232,7 +28232,7 @@ symbolic expressions in pure Python using the technique of logical unification."
          "0w9giq196wps7mbm47c4shdzs5yvwvqajqzkim2p92i51sm5qgvm"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-pytest-6 python-toml))
+     (list python-pytest python-toml))
     (propagated-inputs
      (list python-logical-unification))
     (home-page "https://github.com/pythological/python-cons")