summary refs log tree commit diff
diff options
context:
space:
mode:
authorSughosha via Guix-patches via <guix-patches@gnu.org>2022-10-11 18:34:21 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-29 23:52:15 +0200
commit6db22e526241d5d0de5e52af172de051e30697d7 (patch)
treec630cd904d4e6b7a70f197f0d7a6e818e1f6d7f0
parentd231651696e5eb66895ca446f2e833ec6df4c571 (diff)
downloadguix-6db22e526241d5d0de5e52af172de051e30697d7.tar.gz
gnu: helm: fix not finding Factory Presets
* gnu/packages/music.scm (helm): Fix not finding Factory Presets.
  This change fixes hardcoded paths so that Factory Presets can be found.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/music.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 72299f13f1..04e9c4a2ad 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6109,21 +6109,21 @@ MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
     (name "helm")
     (version "0.9.0")
     (source
-      (origin
-        (method git-fetch)
-        (uri
-          (git-reference
-            (url "https://github.com/mtytel/helm")
-            (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-          (base32
-            "17ys2vvhncx9i3ydg3xwgz1d3gqv4yr5mqi7vr0i0ca6nad6x3d4"))
-        ;; Apply GCC 9 fixes from https://github.com/mtytel/helm/pull/233
-        (patches (search-patches "helm-fix-gcc-9-build.patch"))))
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/mtytel/helm")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "17ys2vvhncx9i3ydg3xwgz1d3gqv4yr5mqi7vr0i0ca6nad6x3d4"))
+       ;; Apply GCC 9 fixes from https://github.com/mtytel/helm/pull/233
+       (patches (search-patches "helm-fix-gcc-9-build.patch"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f  ; no "check" target
+     `(#:tests? #f                      ; no "check" target
        #:make-flags
        (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
              "lv2" "standalone")
@@ -6140,6 +6140,11 @@ MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
              (substitute* "Makefile"
                (("/usr") ""))
              #t))
+         (add-after 'unpack 'fix-hardcoded-paths
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* (list "src/common/load_save.cpp"
+                                "src/editor_sections/patch_browser.cpp")
+               (("/usr") (assoc-ref outputs "out")))))
          (delete 'configure))))
     (inputs
      `(("alsa-lib" ,alsa-lib)