summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-21 23:34:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-21 23:36:12 +0100
commit72876fb02d27425747c2bae8d0f1b2e73a945d31 (patch)
treec14a88e20053e234aab88d7119f3a38ee7d7b475
parentf862d7fb8d3656e7e0ec8ff5ef97db8e46536e93 (diff)
downloadguix-72876fb02d27425747c2bae8d0f1b2e73a945d31.tar.gz
gnu: python-invoke: Delete incompatible and unused code.
* gnu/packages/python-xyz.scm (python-invoke)[arguments]: Add build phase
'delete-python2-code.
(python2-invoke)[arguments]: Remove that phase and add 'delete-python3-code.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f7189e0ddd..244e8ca650 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17862,14 +17862,15 @@ projects.")
      `(#:tests? #f
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'delete-python2-code
+           (lambda _
+             (delete-file-recursively "invoke/vendor/yaml2")))
          (add-after 'unpack 'fix-bash-path
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((bash (assoc-ref inputs "bash")))
                (substitute* "invoke/config.py"
                  (("shell = \"/bin/bash\"")
-                  (string-append "shell = \"" bash "/bin/bash\""))
-                 )
-               #t))))))
+                  (string-append "shell = \"" bash "/bin/bash\"")))))))))
     (inputs
      `(("bash" ,bash-minimal)))
     (synopsis "Pythonic task execution")
@@ -17881,7 +17882,17 @@ instead of servers and network commands.")
     (license license:bsd-3)))
 
 (define-public python2-invoke
-  (package-with-python2 python-invoke))
+  (let ((parent (package-with-python2 python-invoke)))
+    (package
+      (inherit parent)
+      (arguments
+       (substitute-keyword-arguments (package-arguments parent)
+         ((#:phases phases #t)
+          `(modify-phases ,phases
+             (delete 'delete-python2-code)
+             (add-after 'unpack 'delete-python3-code
+               (lambda _
+                 (delete-file-recursively "invoke/vendor/yaml3"))))))))))
 
 (define-public python-automat
   (package