summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-23 00:19:29 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:48 -0500
commit774812df96d2c21dba52e0360927cd78ae97a959 (patch)
tree24331e70f3ae985cb078b87d44a77793feb8c8da
parent0b701d77e7cd880625147e844cf8f0102f5d27d4 (diff)
downloadguix-774812df96d2c21dba52e0360927cd78ae97a959.tar.gz
gnu: python-django: Do not alter PYTHONPATH.
* gnu/packages/django.scm (python-django): Remove trailing #t.
[phases]{pre-check,check}: Do not alter PYTHONPATH.
-rw-r--r--gnu/packages/django.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index aa4411c5a2..091d7571d7 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -74,23 +74,10 @@
              (substitute* "tests/settings_tests/tests.py"
                ((".*def test_incorrect_timezone.*" all)
                 (string-append "    @unittest.skipIf(True, 'Disabled by Guix')\n"
-                               all)))
-
-             ;; Preserve the PYTHONPATH created by Guix when running the tests.
-             (substitute* "tests/admin_scripts/tests.py"
-               (("python_path = \\[")
-                (string-append "python_path = ['"
-                               (string-join
-                                (string-split (getenv "PYTHONPATH") #\:)
-                                "','")
-                               "', ")))
-
-             #t))
+                               all)))))
          (replace 'check
            (lambda _
              (with-directory-excursion "tests"
-               (setenv "PYTHONPATH"
-                       (string-append "..:" (getenv "PYTHONPATH")))
                (invoke "python" "runtests.py"
                        ;; By default tests run in parallel, which may cause
                        ;; various race conditions.  Run sequentially for