summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-11-30 22:32:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-11-30 22:39:34 +0100
commit80fbad4fe655df72212045bb4f5f0b43a8e7734e (patch)
tree118d970c241c70fe5c1beb41ba299f700760f833
parentd3c1b5f66dbee892cecb70148f74efa8492116f2 (diff)
downloadguix-80fbad4fe655df72212045bb4f5f0b43a8e7734e.tar.gz
gnu: pigx-chipseq: Update to 0.0.51.
* gnu/packages/bioinformatics.scm (pigx-chipseq): Update to 0.0.51.
[inputs]: Add r-corrplot, r-deseq2, r-dt, r-ggrepel, r-gprofiler2, r-pheatmap,
and r-rsubread.
-rw-r--r--gnu/packages/bioinformatics.scm23
1 files changed, 15 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5ae50ffddb..477715b9b2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12681,7 +12681,7 @@ expression report comparing samples in an easily configurable manner.")
 (define-public pigx-chipseq
   (package
     (name "pigx-chipseq")
-    (version "0.0.43")
+    (version "0.0.51")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/BIMSBbioinfo/pigx_chipseq/"
@@ -12689,7 +12689,7 @@ expression report comparing samples in an easily configurable manner.")
                                   "/pigx_chipseq-" version ".tar.gz"))
               (sha256
                (base32
-                "0426i31b7mqqkbss5dgrvf5prkj4z1qrd7yrpd27vybs01xhdlks"))))
+                "0bb6hzpl0qq0jd57pgd1m5ns547rfipr6071a4m12vxlm4nlpi5q"))))
     (build-system gnu-build-system)
     ;; parts of the tests rely on access to the network
     (arguments '(#:tests? #f))
@@ -12701,23 +12701,30 @@ expression report comparing samples in an easily configurable manner.")
        ("r-biocparallel" ,r-biocparallel)
        ("r-biostrings" ,r-biostrings)
        ("r-chipseq" ,r-chipseq)
+       ("r-corrplot" ,r-corrplot)
        ("r-data-table" ,r-data-table)
+       ("r-deseq2" ,r-deseq2)
        ("r-dplyr" ,r-dplyr)
+       ("r-dt" ,r-dt)
        ("r-genomation" ,r-genomation)
        ("r-genomicalignments" ,r-genomicalignments)
        ("r-genomicranges" ,r-genomicranges)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-ggrepel" ,r-ggrepel)
+       ("r-gprofiler2" ,r-gprofiler2)
+       ("r-heatmaply" ,r-heatmaply)
+       ("r-htmlwidgets" ,r-htmlwidgets)
+       ("r-jsonlite" ,r-jsonlite)
+       ("r-pheatmap" ,r-pheatmap)
+       ("r-plotly" ,r-plotly)
+       ("r-rmarkdown" ,r-rmarkdown)
        ("r-rsamtools" ,r-rsamtools)
+       ("r-rsubread" ,r-rsubread)
        ("r-rtracklayer" ,r-rtracklayer)
        ("r-s4vectors" ,r-s4vectors)
        ("r-stringr" ,r-stringr)
        ("r-tibble" ,r-tibble)
        ("r-tidyr" ,r-tidyr)
-       ("r-jsonlite" ,r-jsonlite)
-       ("r-heatmaply" ,r-heatmaply)
-       ("r-htmlwidgets" ,r-htmlwidgets)
-       ("r-ggplot2" ,r-ggplot2)
-       ("r-plotly" ,r-plotly)
-       ("r-rmarkdown" ,r-rmarkdown)
        ("python-wrapper" ,python-wrapper)
        ("python-pyyaml" ,python-pyyaml)
        ("python-magic" ,python-magic)