summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-24 21:31:56 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-24 21:31:56 -0400
commit971f00f237b5d5e40e1b1505dd4953f491575a6d (patch)
treeecf66a969f52c62517103ea51a9f3e72842b0eb1
parentc9f82d57eb40d8ed4ca1c7ddf03d0f7284d7f9c2 (diff)
downloadguix-971f00f237b5d5e40e1b1505dd4953f491575a6d.tar.gz
gnu: python-tlsh: Fix build.
* gnu/packages/python-xyz.scm (python-tlsh) [build-system]: Switch to
python-build-system.
[arguments]: Remove #:out-of-source.  Remove install phase override.  Add a
configure, chdir and adjust the check phase override.
[inputs]: Delete field.
[native-inputs]: New field.
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 10 insertions, 20 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b7718d6d6d..856fc9adb9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13490,32 +13490,22 @@ $ rm -rf /tmp/env
        (file-name (git-file-name name version))
        (sha256
         (base32 "1gb5j73nw3nmx030rf8pm75rns5syxhv44zxr6i74kjicyly1i9w"))))
-    (build-system cmake-build-system)
+    (build-system python-build-system)
     (arguments
-     (list #:out-of-source? #f
-           #:phases
+     (list #:phases
            #~(modify-phases %standard-phases
-               (replace 'install
+               (add-before 'build 'configure
+                 (lambda _
+                   (invoke "cmake" ".")))      ;to generate tlsh_version.h
+               (add-after 'configure 'chdir
                  (lambda _
-                   ;; Build and install the Python bindings.  The underlying
-                   ;; C++ library is apparently not meant to be installed.
-                   (with-directory-excursion "py_ext"
-                     (and (system* "python" "setup.py" "build")
-                          (system* "python" "setup.py" "install"
-                                   (string-append "--prefix=" #$output))))))
-               ;; Delay tests until the phase above has run.
-               (delete 'check)
-               (add-after 'install 'check
+                   (chdir "py_ext")))
+               (replace 'check
                  (lambda* (#:key tests? #:allow-other-keys)
-                   (substitute* "Testing/python_test.sh"
-                     ;; The script sets up a working PYTHONPATH, but does not
-                     ;; export it for all subsequent test commands.  Fix that.
-                     (("^PYTHONPATH=\".*" all)
-                      (string-append all "\nexport PYTHONPATH\n")))
                    (when tests?
-                     (with-directory-excursion "Testing"
+                     (with-directory-excursion "../Testing"
                        (invoke "./python_test.sh"))))))))
-    (inputs (list python-wrapper))      ;for the bindings
+    (native-inputs (list cmake-minimal))
     (synopsis "Fuzzy matching library for Python")
     (description
      "Trend Micro Locality Sensitive Hash (TLSH) is a fuzzy matching library.