summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 20:31:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:33 +0100
commit9dfc79b34c5f5a131e495aaf71c05dffe6e1b966 (patch)
tree3070575636b73f198babbbfcb93a07b38b88e403
parent1b1a1067d03d383398ccee6c39c8994d03abc99c (diff)
downloadguix-9dfc79b34c5f5a131e495aaf71c05dffe6e1b966.tar.gz
gnu: Add ghc-th-abstraction.
* gnu/packages/haskell.scm (ghc-th-abstraction): New variable.
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 192a227600..e0e61547d5 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4716,6 +4716,29 @@ asynchronous exceptions.")
      "This deprecated library provides an implementation of packed strings.")
     (license license:bsd-3)))
 
+(define-public ghc-th-abstraction
+  (package
+    (name "ghc-th-abstraction")
+    (version "0.2.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "th-abstraction/th-abstraction-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0g42h6wnj2awc5ryhbvx009wd8w75pn66bjzsq1z4s3xajd2hbp5"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/glguy/th-abstraction")
+    (synopsis "Nicer interface for reified information about data types")
+    (description
+     "This package normalizes variations in the interface for inspecting
+datatype information via Template Haskell so that packages and support a
+single, easier to use informational datatype while supporting many versions of
+Template Haskell.")
+    (license license:isc)))
+
 (define-public ghc-th-lift
   (package
     (name "ghc-th-lift")