summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-28 19:33:34 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-30 00:00:47 +0100
commit9e6b0775f42c295d559ce676370fcf06287b87a7 (patch)
tree4bd98b1df6111b9004b8fbceed500e791f82402c
parent06e39eafd7d8279b0b97424c9c32f60a31bfce30 (diff)
downloadguix-9e6b0775f42c295d559ce676370fcf06287b87a7.tar.gz
gnu: python-hy: Update to 0.20.0.
* gnu/packages/python-xyz.scm (python-hy): Update to 0.20.0.
[source]: Fetch from GitHub.
[arguments]<#:phases>: Remove 'set-HOME phase. Replace nosetests command with
pytest in the custom 'check phase and skip failed tests.
[native-inputs]: Remove python-coverage, python-nose. Add python-pytest.
[propagated-inputs]: Order alphabetically.
[home-page]: Follow redirection.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d7b6ad76b4..9b651d2108 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13007,30 +13007,32 @@ with a new public API, and RPython support.")
 (define-public python-hy
   (package
     (name "python-hy")
-    (version "0.18.0")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "hy" version))
-              (sha256
-               (base32
-                "04dfwm336gw61fmgwikvh0cnxk682p19b4w555wl5d7mlym4rwj2"))))
+    (version "0.20.0")
+    (source
+     (origin
+       (method git-fetch)               ; no tests in PyPI release
+       (uri (git-reference
+             (url "https://github.com/hylang/hy")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1g7djra9z7b0wyqyfrk2n4z3zamp2xkahv00jwdv35xmwwn09hq4"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-before 'install 'set-HOME
-           (lambda _
-             (setenv "HOME" "/tmp") #t))
          (replace 'check
            (lambda _
-             ;; Tests require write access to HOME.
-             (setenv "HOME" "/tmp")
-             (invoke "nosetests"))))))
+             (invoke "python" "-m" "pytest" "-k"
+                     (string-append     ; skip some failed tests
+                      "not test_bin_hy_sys_executable"
+                      " and not test_bin_hy_circular_macro_require"
+                      " and not test_macro_from_module")))))))
     (native-inputs
-     (list python-coverage python-nose))
+     (list python-pytest))
     (propagated-inputs
-     (list python-astor python-colorama python-rply python-funcparserlib))
-    (home-page "http://hylang.org/")
+     (list python-astor python-colorama python-funcparserlib python-rply))
+    (home-page "https://docs.hylang.org/en/stable/")
     (synopsis "Lisp frontend to Python")
     (description
      "Hy is a dialect of Lisp that's embedded in Python.  Since Hy transforms