summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-23 16:56:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:16 +0300
commita44a6fc4a927cdf80dd9e5343ab8313be6dc0df0 (patch)
tree59be6e7683e92ce1d3ee12125e9e1b12adfcbb1e
parent7a550179e5f8b9cd427a0e17a857e30c7a839f2f (diff)
downloadguix-a44a6fc4a927cdf80dd9e5343ab8313be6dc0df0.tar.gz
gnu: Add rust-nanorand-0.7.
* gnu/packages/crates-io.scm (rust-nanorand-0.7): New variable.
(rust-nanorand-0.5): Inherit from rust-nanorand-0.7.
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 26 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 15ebb311ee..46467aefad 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35541,8 +35541,33 @@ library.")
 libmysqlclient.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-nanorand-0.7
+  (package
+    (name "rust-nanorand")
+    (version "0.7.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "nanorand" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32 "1hr60b8zlfy7mxjcwx2wfmhpkx7vfr3v9x12shmv1c10b0y32lba"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-getrandom" ,rust-getrandom-0.2)
+        ("rust-zeroize" ,rust-zeroize-1))
+       #:cargo-development-inputs
+       (("rust-hex" ,rust-hex-0.4))))
+    (home-page "https://github.com/Absolucy/nanorand-rs")
+    (synopsis "Tiny, fast, zero-dep library for random number generation")
+    (description
+     "This library is meant for fast, random number generation with
+quick compile time, and minimal dependencies.")
+    (license license:zlib)))
+
 (define-public rust-nanorand-0.5
   (package
+    (inherit rust-nanorand-0.7)
     (name "rust-nanorand")
     (version "0.5.1")
     (source
@@ -35552,7 +35577,6 @@ libmysqlclient.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "1ryi6jdfsfij4di33f269099g7m32rlr7sv7j4pklnjcj2xxfwri"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #true              ;error with pre-release randomize
        #:cargo-inputs
@@ -35563,13 +35587,7 @@ libmysqlclient.")
         ("rust-fastrand" ,rust-fastrand-1)
         ("rust-hex" ,rust-hex-0.4)
         ("rust-random-fast-rng" ,rust-random-fast-rng-0.1)
-        ("rust-randomize" ,rust-randomize-4))))
-    (home-page "https://github.com/aspenluxxxy/nanorand-rs")
-    (synopsis "Tiny, fast, zero-dep library for random number generation")
-    (description
-     "This library is meant for fast, random number generation with
-quick compile time, and minimal dependencies.")
-    (license license:zlib)))
+        ("rust-randomize" ,rust-randomize-4))))))
 
 (define-public rust-nanorand-0.4
   (package