summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:00 +0200
commita7255dd13fb6ecb382588ab0c45ffe52a01a9edb (patch)
treebf753bc1a78b9451fd9f78d0c75a0268f47f416d
parent7c52cad0464175370c44bd4695e4c01a62b8268f (diff)
downloadguix-a7255dd13fb6ecb382588ab0c45ffe52a01a9edb.tar.gz
gnu: oneko: Remove trailing #t from phases.
* gnu/packages/toys.scm (oneko)[source]: Don't explicitly return #t from snippet…
[arguments]: …nor from phases.
-rw-r--r--gnu/packages/toys.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 09426fe6fa..d80c37d5fb 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -57,8 +57,7 @@
            (for-each delete-file-recursively
                      (cons* "bitmaps/bsd" "bitmaps/sakura" "bitmaps/tomoyo"
                             "bitmasks/bsd" "bitmasks/sakura" "bitmasks/tomoyo"
-                            (find-files "cursors" "(bsd|card|petal).*\\.xbm")))
-           #t))))
+                            (find-files "cursors" "(bsd|card|petal).*\\.xbm")))))))
     (build-system gnu-build-system)
     (native-inputs
      (list imake))
@@ -73,8 +72,7 @@
              (invoke "xmkmf")
              ;; Fix incorrectly generated compiler flags.
              (substitute* "Makefile"
-               (("(CDEBUGFLAGS = ).*" _ front) (string-append front "-O2\n")))
-             #t))
+               (("(CDEBUGFLAGS = ).*" _ front) (string-append front "-O2\n")))))
          (replace 'install
            (lambda* (#:key outputs make-flags #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -89,8 +87,7 @@
                (copy-file "oneko.man" (string-append man6 "/oneko.6"))
                (copy-file "oneko.man.jp" (string-append man6-ja "/oneko.6"))
                (for-each (lambda (file) (install-file file doc))
-                         (find-files "." "README.*")))
-             #t)))))
+                         (find-files "." "README.*"))))))))
     (home-page "http://www.daidouji.com/oneko/")
     (synopsis "Cute cat chasing your mouse pointer")
     (description "Displays a cat or another animated character that chases the