summary refs log tree commit diff
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-03 22:12:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-05 13:43:36 +0200
commitb61ee34c9d7b679cb772e6e8ff0c0876ccf087b1 (patch)
treef5fda06efac9352794a75a599db89216683ac29b
parent612e5b8528e1f4f9c1c03ba7fa01997ca16f4250 (diff)
downloadguix-b61ee34c9d7b679cb772e6e8ff0c0876ccf087b1.tar.gz
gnu: Add emacs-djvu3.
* gnu/packages/emacs-xyz.scm (emacs-djvu3): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 63de8bea05..676b3d35e9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3105,6 +3105,46 @@ filters, new key bindings and faces.  It can be enabled by
 DjVuLibre, see @url{http://djvu.sourceforge.net/}.")
     (license license:gpl3+)))
 
+(define-public emacs-djvu3
+  ;; Commit from 2021-06-03.
+  (let ((commit "37b675be1d4d436cdd0c3b5d3f13e88b59a7bf18")
+        (revision "0"))
+    (package
+      (name "emacs-djvu3")
+      ;; `Version:' header says 1.0
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/dalanicolai/djvu3")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0p0izjrgbayx5ybk1n6db5hbrjv9d4kpn57w4iyxdm3h96sp9cmr"))))
+      (propagated-inputs
+       `(("emacs-djvu" ,emacs-djvu)
+         ("emacs-tablist" ,emacs-tablist)))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/dalanicolai/djvu3")
+      (synopsis "Extend djvu.el to display annotations and more")
+      (description "This package extends @code{emacs-djvu} with annotation
+rendering features and a fast occur search feature using @code{svg.el}.
+
+Other features include:
+
+@itemize
+@item clickable links
+@item marker extension to @code{svg.el} for providing arrowheads (or other
+types of markers)
+@item a quite fancy keyboard annotation function
+@item an @code{imenu} index function to enable imenu navigation
+@item document restore function to open the document at the last location of
+the previous session
+@end itemize")
+      (license license:gpl3+))))
+
 (define-public emacs-pabbrev
   (package
     (name "emacs-pabbrev")