summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-09 21:57:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-09 22:30:42 +0100
commitb688e283dc46d9f3a8e7be5350015655484b952b (patch)
tree5590fc39c92aad13fb0895609f2fb3086843d69d
parentf62ac25ca38ba3cf8549fff5faf1189effda7e5f (diff)
downloadguix-b688e283dc46d9f3a8e7be5350015655484b952b.tar.gz
gnu: Add r-httr2.
* gnu/packages/cran.scm (r-httr2): New variable.
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d6621c4edc..936c34c1a2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2802,6 +2802,38 @@ particularly easy to create complete web applications using httpuv alone.")
     ;; obtained here: https://github.com/rstudio/httpuv/blob/master/LICENSE
     (license license:gpl3+)))
 
+(define-public r-httr2
+  (package
+    (name "r-httr2")
+    (version "0.2.2")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "httr2" version))
+              (sha256
+               (base32
+                "1gzjsw3w7c3rsp3gb9rdbfmmnmd2sq09s3wza49730gp84jvc6jx"))))
+    (properties `((upstream-name . "httr2")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-cli
+           r-curl
+           r-glue
+           r-magrittr
+           r-openssl
+           r-r6
+           r-rappdirs
+           r-rlang
+           r-withr))
+    (native-inputs (list r-knitr))
+    (home-page "https://httr2.r-lib.org")
+    (synopsis "Perform HTTP requests and process the responses")
+    (description
+     "This package provides tools for creating and modifying HTTP requests,
+then performing them and processing the results.  @code{httr2} is a
+re-imagining of @code{httr} that uses a pipe-based interface and solves more
+of the problems that API wrapping packages face.")
+    (license license:expat)))
+
 (define-public r-jsonlite
   (package
     (name "r-jsonlite")