summary refs log tree commit diff
diff options
context:
space:
mode:
authorDaniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>2022-08-09 15:07:06 +0200
committer宋文武 <iyzsong@member.fsf.org>2022-08-10 15:16:53 +0800
commitb72459a861d7029d69e9e3ffe3dd411b452e26de (patch)
tree21a110f17d2dbbb1ec1eb8b5728618e107d8077a
parent59ee837d8b11d7d688045b601e8b240ccbdbe7c7 (diff)
downloadguix-b72459a861d7029d69e9e3ffe3dd411b452e26de.tar.gz
gnu: maxima: Fix to find info files.
The Maxima command ‘describe’ allows to pick the relevant portions from
Maxima’s Texinfo docs.  However it does not support reading gzipped info
files.

* gnu/packages/maths.scm (maxima)[arguments]<phases>: Delete
'compress-documentation phase.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e32a71100e..52a6d6259f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4435,7 +4435,11 @@ to BMP, JPEG or PNG image formats.")
                ;; components at runtime.
                (wrap-program (string-append out "/bin/maxima")
                  `("PATH" prefix (,binutils))))
-             #t)))))
+             #t))
+         ;; The Maxima command ‘describe’ allows to pick the relevant portions
+         ;; from Maxima’s Texinfo docs.  However it does not support reading
+         ;; gzipped info files.
+         (delete 'compress-documentation))))
     (home-page "https://maxima.sourceforge.io")
     (synopsis "Numeric and symbolic expression manipulation")
     (description "Maxima is a system for the manipulation of symbolic and