summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-17 21:00:21 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-17 22:51:55 +0100
commitb83247f9a02a9874a2a3a35cf5992cd6809cf380 (patch)
tree931e2582c1f4884e9fe4bba233164cb53bb17c9b
parentb014c35081e9087f67c00c0f25be3b88884862c2 (diff)
downloadguix-b83247f9a02a9874a2a3a35cf5992cd6809cf380.tar.gz
gnu: memkind: Update to 1.12.0.
* gnu/packages/disk.scm (memkind): Update to 1.12.0.
[arguments]: Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/disk.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 8475bb12d3..3ab65e60d4 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1177,7 +1177,7 @@ that support this feature).")
 (define-public memkind
   (package
     (name "memkind")
-    (version "1.11.0")
+    (version "1.12.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1185,8 +1185,7 @@ that support this feature).")
                     (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
-               (base32
-                "0w5hws12l167mbr4n6a6fl0mhf8mci61fsn55lh2cxz33f7q8n2x"))))
+               (base32 "1s52vl2jlrdc8nxnvf993x9mcag56qxcaniiijhmsv42a26hvjk4"))))
     (build-system gnu-build-system)
     (inputs
      (list ;; memkind patched jemalloc to add je_arenalookupx,
@@ -1209,8 +1208,7 @@ that support this feature).")
                 (("/bin/sh") (which "sh")))
                (invoke "autoconf")
                (substitute* "configure"
-                (("/bin/sh") (which "sh"))))
-             #t)))))
+                (("/bin/sh") (which "sh")))))))))
     (home-page "https://github.com/memkind/memkind")
     (synopsis "Heap manager with memory kinds (for NUMA)")
     (description "This package provides a user-extensible heap manager