summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-17 22:39:44 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 19:52:56 +0100
commitb90b5df70901fe9ca4783f2591df120330cb8861 (patch)
tree03d0296cd341a27f2c757a02d943108878ff3602
parentf98aba9b7b7d1db75d8df663af87722c8bdad0bc (diff)
downloadguix-b90b5df70901fe9ca4783f2591df120330cb8861.tar.gz
gnu: Add rust-gjson-0.8.
* gnu/packages/crates-io.scm (rust-gjson-0.8): New variable.
(rust-gjson-0.7): Inherit from above.
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2406fe3d6e..8820133b5e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21663,17 +21663,17 @@ reading and writing git repositories.")
 libcurl, which is intended to be used with the @code{git2} crate.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-gjson-0.7
+(define-public rust-gjson-0.8
   (package
     (name "rust-gjson")
-    (version "0.7.5")
+    (version "0.8.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "gjson" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "0vhary4ha77scriaw6r4nv16ha9pfzirm84sjc240csqwb542p10"))))
+        (base32 "164nwjx81j8cnnvi63h0dcxdc9ib3s0k9wx15l72hxp4vklx16a5"))))
     (build-system cargo-build-system)
     (arguments `(#:skip-build? #t))
     (home-page "https://github.com/tidwall/gjson.rs")
@@ -21681,6 +21681,20 @@ libcurl, which is intended to be used with the @code{git2} crate.")
     (description "Gjson is a JSON parser for Rust.")
     (license license:expat)))
 
+(define-public rust-gjson-0.7
+  (package
+    (inherit rust-gjson-0.8)
+    (name "rust-gjson")
+    (version "0.7.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "gjson" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0vhary4ha77scriaw6r4nv16ha9pfzirm84sjc240csqwb542p10"))))
+    (arguments `(#:skip-build? #t))))
+
 (define-public rust-glam-0.17
   (package
     (name "rust-glam")