summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-09 23:52:39 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-09 23:54:55 +0200
commitba04571a833e70860bb67ad9af8255b51031ea22 (patch)
tree25be52cd777ac34e077545d0d02a29eeb79b27fa
parentf88aeb6aa891f27c98af656498ca7857e610c6a7 (diff)
downloadguix-ba04571a833e70860bb67ad9af8255b51031ea22.tar.gz
gnu: Add ALSA-lib; use it.
* gnu/packages/linux.scm (alsa-lib): New variable.
* gnu/packages/oggvorbis.scm (ao): Add ALSA-lib as an input.
-rw-r--r--gnu/packages/linux.scm20
-rw-r--r--gnu/packages/oggvorbis.scm7
2 files changed, 24 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 734997ae57..0708b5cb81 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -429,3 +429,23 @@ slabtop, and skill.")
      "strace is a system call tracer, i.e. a debugging tool which prints out a
 trace of all the system calls made by a another process/program.")
     (license bsd-3)))
+
+(define-public alsa-lib
+  (package
+    (name "alsa-lib")
+    (version "1.0.27.1")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-"
+                   version ".tar.bz2"))
+             (sha256
+              (base32
+               "0fx057746dj7rjdi0jnvx2m9b0y1lgdkh1hks87d8w32xyihf3k9"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.alsa-project.org/")
+    (synopsis "The Advanced Linux Sound Architecture libraries")
+    (description
+     "The Advanced Linux Sound Architecture (ALSA) provides audio and
+MIDI functionality to the Linux-based operating system.")
+    (license lgpl2.1+)))
diff --git a/gnu/packages/oggvorbis.scm b/gnu/packages/oggvorbis.scm
index 888e5715f2..2aa606ca22 100644
--- a/gnu/packages/oggvorbis.scm
+++ b/gnu/packages/oggvorbis.scm
@@ -25,6 +25,7 @@
   #:use-module (gnu packages libpng)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages linux)
   #:use-module ((guix licenses)
                 #:renamer (symbol-prefix-proc 'license:))
   #:use-module (guix packages)
@@ -118,9 +119,9 @@ data (e.g., voice mail), and audio books.")
         "1m0v2y6bhr4iwsgdkc7b3y0qgpvpv1ifbxsy8n8ahsvjn6wmppi9"))))
     (build-system gnu-build-system)
     ;; FIXME: Add further backends, see the summary printed after configure.
-    (inputs `(("pkg-config" ,pkg-config)))
-    (synopsis
-     "libao, a cross platform audio library")
+    (inputs `(("pkg-config" ,pkg-config)
+              ("alsa-lib" ,alsa-lib)))
+    (synopsis "Cross platform audio library")
     (description
      "Libao is a cross-platform audio library that allows programs to
 output audio using a simple API on a wide variety of platforms.