summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-06-05 11:23:10 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-06-05 11:23:10 +0200
commitba9cbb66126df73363ac3a3ccc8e2843f1753168 (patch)
treee3b778140b676e45f23f3c1afd5a8b4992e3b4a3
parentf9ef881e4dea6f7fdbe5c4be59d54b34f2b62f36 (diff)
downloadguix-ba9cbb66126df73363ac3a3ccc8e2843f1753168.tar.gz
gnu: Add libfec.
* gnu/packages/radio.scm (libfec): New variable.
-rw-r--r--gnu/packages/radio.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index c511fd7e8c..dd3771d786 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -94,6 +94,34 @@
   #:use-module (guix build-system python)
   #:use-module (guix build-system qt))
 
+(define-public libfec
+  ;; Use commit to get compilation fixes that are not in a release yet.
+  (let ((commit "9750ca0a6d0a786b506e44692776b541f90daa91")
+        (revision "1"))
+    (package
+      (name "libfec")
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/quiet/libfec")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0i6jhrdswr1wglyb9h39idpz5v9z13yhidvlbj34vxpyngrkhlvs"))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")
+         #:test-target "test_all"))
+      (home-page "https://github.com/quiet/libfec")
+      (synopsis "Forward error correction algorithms library")
+      (description
+       "This package provides a set of functions that implement several popular
+@dfn{forward error correction} (FEC) algorithms and several low-level routines
+useful in modems implemented with @dfn{digital signal processing} (DSP).")
+      (license license:lgpl2.1))))
+
 (define-public liquid-dsp
   (package
     (name "liquid-dsp")