summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-04-27 22:49:03 -0400
committerLeo Famulari <leo@famulari.name>2023-04-30 04:47:19 -0400
commitbdbf3e36cfed2a6e373bc32868264d85ec4932ac (patch)
tree7329d1abe31713b0614440d2c6cdb79c5f16e599
parent15172a5c1e8290c0105583db41dcaff7dcf60a31 (diff)
downloadguix-bdbf3e36cfed2a6e373bc32868264d85ec4932ac.tar.gz
gnu: 389-ds-base: Make sure not to keep a store reference to HTTPD.
* gnu/packages/openldap.scm (389-ds-base)[inputs]: Move httpd ...
[native-inputs]: ... to here.
[arguments]: Forbid keeping a reference to httpd.
-rw-r--r--gnu/packages/openldap.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 92480b13f8..40b708145a 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -233,6 +233,7 @@ servers from Python programs.")
                   (guix build utils))
       #:imported-modules `((guix build python-build-system)
                            ,@%gnu-build-system-modules)
+      #:disallowed-references (list httpd)
       #:configure-flags
       #~(list "--enable-cmocka"
               (string-append "--with-db="
@@ -322,7 +323,6 @@ servers from Python programs.")
            cracklib
            cyrus-sasl
            gnutls
-           httpd
            icu4c
            iproute
            json-c
@@ -353,6 +353,7 @@ servers from Python programs.")
            cmocka
            doxygen
            gettext-minimal
+           httpd
            libtool
            rsync
            pkg-config))