summary refs log tree commit diff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-05-11 19:41:37 +0000
committerLudovic Courtès <ludo@gnu.org>2023-05-18 19:55:33 +0200
commitc1007786fdec6c749887bbd9bf8f46ff27e69055 (patch)
treeadad0049ab537a4df04d101468282fcadcdd3a2d
parent7db7d4476f4042ca20b189fccd139f49b614d9f0 (diff)
downloadguix-c1007786fdec6c749887bbd9bf8f46ff27e69055.tar.gz
gnu: f3d: Update to 2.0.0.
* gnu/packages/graphics.scm (f3d): Update to 2.0.0.
[source]: Update substitute paths and add patch for breaking change to
cxxopts.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/graphics.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index fa1fcbf4d1..60db7543a6 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2483,7 +2483,7 @@ a tetrahedral mesh, isovalue discretization and Lagrangian movement;
 (define-public f3d
   (package
     (name "f3d")
-    (version "1.3.1")
+    (version "2.0.0")
     (source
      (origin
        (method git-fetch)
@@ -2492,16 +2492,21 @@ a tetrahedral mesh, isovalue discretization and Lagrangian movement;
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0hdfgwf5d24ykab634xg4vv9r09nh96ss7hhnqnh5nmw4abhxzg7"))
+        (base32 "1gcwpdkz3ylaxi133zri1cxkvj6za5s1hbgqqc8fn10q2dkkdd44"))
        (modules '((guix build utils)))
        (snippet
         #~(begin
-            (delete-file "application/cxxopts.hpp")
-            (delete-file "application/json.hpp")
+            (delete-file "external/cxxopts.hpp")
+            (delete-file "external/json.hpp")
             (substitute* "application/F3DOptionsParser.cxx"
               (("^#include \"cxxopts\\.hpp\"")
                "#include <cxxopts.hpp>")
               (("^#include \"json\\.hpp\"")
+               "#include <nlohmann/json.hpp>")
+              (("cxxopts::OptionException")
+               "cxxopts::exceptions::parsing"))
+            (substitute* "library/src/engine.cxx"
+              (("^#include <json\\.hpp>")
                "#include <nlohmann/json.hpp>"))))))
     (build-system cmake-build-system)
     ;; The package cannot easily be split into out and lib outputs because