summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-17 00:12:35 +0200
committerMarius Bakke <marius@gnu.org>2022-07-23 19:43:10 +0200
commitc84fa7a253b3405f8f29e79ac65546eea2562641 (patch)
treeb96f8c1cb75d7c0d3cdb46514c8146b1aac5f8b3
parent9e4b3391c559ac4c6b5bedf08f8350b51948eaa2 (diff)
downloadguix-c84fa7a253b3405f8f29e79ac65546eea2562641.tar.gz
gnu: libtool: Don't reference bash by label.
* gnu/packages/autotools.scm (libtool)[arguments]: Use SEARCH-INPUT-FILE
instead of label.
-rw-r--r--gnu/packages/autotools.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index c702be43fa..0357af8850 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -475,10 +475,9 @@ Makefile, simplifying the entire process for the developer.")
                         (number->string (parallel-job-count))
                         "1")))
            ;; Patch references to /bin/sh.
-           (let ((bash (assoc-ref (or native-inputs inputs) "bash")))
+           (let ((/bin/sh (search-input-file (or native-inputs inputs) "bin/sh")))
              (substitute* "tests/testsuite"
-               (("/bin/sh")
-                (string-append bash "/bin/sh"))))))
+               (("/bin/sh") /bin/sh)))))
          ;; These files may be copied into source trees by libtoolize,
          ;; therefore they must not point to store file names that would be
          ;; leaked with tarballs generated by make dist.