summary refs log tree commit diff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2023-05-26 23:51:28 +0900
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-01 10:54:53 +0200
commitd3eebaf71dda8c1828aeb90596fa06d97eed67cc (patch)
tree68a1fb0f61456d04837c0b6261879f8665f87ce3
parent9c0d8c44ba1aecb46e9a13604bf1bb8c1058d625 (diff)
downloadguix-d3eebaf71dda8c1828aeb90596fa06d97eed67cc.tar.gz
gnu: Add font-intel-one-mono
* gnu/packages/fonts.scm (font-intel-one-mono): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/fonts.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 53b76650bc..526bfc6864 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -55,6 +55,7 @@
 ;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
 ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -185,6 +186,28 @@ well as other mediums.")
 in print.  With attention to detail for high resolution rendering.")
     (license license:silofl1.1)))
 
+(define-public font-intel-one-mono
+  (package
+    (name "font-intel-one-mono")
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/intel/intel-one-mono")
+                    (commit "9effabe19a60bdd46cbfbdcc6e81facd8a13b762")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "12lywni8bgkr8h4pz1lkw4imr2y896rnsvipbqgqv3c1b54b5g7n"))))
+    (build-system font-build-system)
+    (home-page "https://github.com/intel/intel-one-mono")
+    (synopsis "Expressive monospaced font family")
+    (description
+     "This package provides Intel One Mono, an expressive monospaced font
+family that's built with clarity, legibility, and the needs of developers in
+mind.")
+    (license license:silofl1.1)))
+
 (define-public font-dejavu
   (package
     (name "font-dejavu")