summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 12:55:03 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:20 -0500
commitd44732025e286fde4cba6b86d69b0968a3fe9c03 (patch)
tree611a64cd862e32b43ed7e7feaf9532e557ebeee0
parentb6d9777f49e5147eae25df0b766960ec0d6ba3bc (diff)
downloadguix-d44732025e286fde4cba6b86d69b0968a3fe9c03.tar.gz
gnu: ghc-network: Update to 2.8.0.1.
* gnu/packages/haskell-xyz.scm (ghc-network): Update to 2.8.0.1.
(ghc-network-2.8): Remove variable.
* gnu/packages/idris.scm (idris)[inputs]: Replace 'ghc-network-2.8' with
'ghc-network'.
-rw-r--r--gnu/packages/haskell-xyz.scm22
-rw-r--r--gnu/packages/idris.scm2
2 files changed, 3 insertions, 21 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 9c08b96715..4b628f311c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6850,7 +6850,7 @@ ncurses.")
 (define-public ghc-network
   (package
     (name "ghc-network")
-    (version "2.6.3.6")
+    (version "2.8.0.1")
     (outputs '("out" "doc"))
     (source
      (origin
@@ -6861,7 +6861,7 @@ ncurses.")
              ".tar.gz"))
        (sha256
         (base32
-         "198mam7ahny48p9fajznbqq16a8ya2gw0xm3gnm1si1rmc4hdplv"))))
+         "0im8k51rw3ahmr23ny10pshwbz09jfg0fdpam0hzf2hgxnzmvxb1"))))
     (build-system haskell-build-system)
     ;; The regression tests depend on an unpublished module.
     (arguments `(#:tests? #f))
@@ -6876,24 +6876,6 @@ ncurses.")
      "This package provides a low-level networking interface.")
     (license license:bsd-3)))
 
-;;; Until we update our default GHC to >=8.6 we cannot update our ghc-network
-;;; package, since the 'cabal-install' package that supports the current
-;;; 'Cabal' module requires 'network==2.6.*'.  Here we provide an updated
-;;; version to be used for our idris package.
-(define-public ghc-network-2.8
-  (hidden-package
-   (package
-     (inherit ghc-network)
-     (version "2.8.0.1")
-     (source
-      (origin
-        (method url-fetch)
-        (uri (string-append "https://hackage.haskell.org/package/network/"
-                            "network-" version ".tar.gz"))
-        (sha256
-         (base32
-          "0im8k51rw3ahmr23ny10pshwbz09jfg0fdpam0hzf2hgxnzmvxb1")))))))
-
 (define-public ghc-network-info
   (package
     (name "ghc-network-info")
diff --git a/gnu/packages/idris.scm b/gnu/packages/idris.scm
index 7e6ee302b0..cd682832bc 100644
--- a/gnu/packages/idris.scm
+++ b/gnu/packages/idris.scm
@@ -71,7 +71,7 @@
        ("ghc-ieee754" ,ghc-ieee754)
        ("ghc-libffi" ,ghc-libffi)
        ("ghc-megaparsec" ,ghc-megaparsec-7)
-       ("ghc-network" ,ghc-network-2.8)
+       ("ghc-network" ,ghc-network)
        ("ghc-optparse-applicative" ,ghc-optparse-applicative)
        ("ghc-regex-tdfa" ,ghc-regex-tdfa)
        ("ghc-safe" ,ghc-safe)