summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-30 21:49:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-30 21:49:51 -0400
commitd4683547e81c0cdde33b751efb5493b2ac2901d5 (patch)
treea88ee303c39791c72d58e27a32eea1069e8b8272
parent68b3e927c7172fe2390160969df109d8fd6cf082 (diff)
downloadguix-d4683547e81c0cdde33b751efb5493b2ac2901d5.tar.gz
gnu: ruby-pg: Update to 1.4.6.
* gnu/packages/ruby.scm (ruby-pg): Update to 1.4.6.
-rw-r--r--gnu/packages/ruby.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3600ecf1df..0777d12095 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7799,7 +7799,7 @@ alternative to Marshal for Object serialization.")
 (define-public ruby-pg
   (package
     (name "ruby-pg")
-    (version "1.3.5")
+    (version "1.4.6")
     (home-page "https://github.com/ged/ruby-pg")
     (source
      (origin
@@ -7810,7 +7810,7 @@ alternative to Marshal for Object serialization.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0c2k2cibd5wwdhva68j5hhfpybm3wmvn2ym4ppn5mqmddwkjkvnk"))))
+         "0k7jgx7x7p6gbsbrv2l5rq27nff2nphnls1sdq525d82b068qnfm"))))
     (build-system ruby-build-system)
     (arguments
      (list
@@ -7842,10 +7842,8 @@ alternative to Marshal for Object serialization.")
                              (string-append (getenv "GEM_PATH") ":" new-gem))
                      (when tests?
                        (invoke "rspec"))))))))
-    (native-inputs
-     (list ruby-rake-compiler ruby-hoe ruby-rspec))
-    (inputs
-     (list postgresql))
+    (native-inputs (list ruby-rake-compiler ruby-hoe ruby-rspec))
+    (inputs (list postgresql))
     (synopsis "Ruby interface to PostgreSQL")
     (description "Pg is the Ruby interface to the PostgreSQL RDBMS.  It works
 with PostgreSQL 9.0 and later.")