summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-10 22:17:09 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-04-10 23:25:35 +0200
commitd8cf1b32d2c9b816807ff31ffed58a9a50d633fe (patch)
tree805eb404dc80e9d6084c1b34432b1a627c3a88ab
parentca708858b12059e22d8d5e90aacc24ca8eb798d8 (diff)
downloadguix-d8cf1b32d2c9b816807ff31ffed58a9a50d633fe.tar.gz
gnu: libzen: Update to 0.4.38.
* gnu/packages/cpp.scm (libzen): Update to 0.4.38.
[source]: Hard-code NAME.
-rw-r--r--gnu/packages/cpp.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 84a7e68b88..2248ebfc4b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -47,18 +47,18 @@
 (define-public libzen
   (package
     (name "libzen")
-    (version "0.4.37")
+    (version "0.4.38")
     (source (origin
               (method url-fetch)
               ;; Warning: This source has proved unreliable 1 time at least.
               ;; Consider an alternate source or report upstream if this
               ;; happens again.
               (uri (string-append "https://mediaarea.net/download/source/"
-                                  name "/" version "/"
-                                  name "_" version ".tar.bz2"))
+                                  "libzen/" version "/"
+                                  "libzen_" version ".tar.bz2"))
               (sha256
                (base32
-                "1dkqbgabzpa6bd7dkqrvd35sdxrhr6qxalb88f3dw0afk65xqb0k"))))
+                "1nkygc17sndznpcf71fdrhwpm8z9a3hc9csqlafwswh49axhfkjr"))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
@@ -66,7 +66,7 @@
     (build-system gnu-build-system)
     (arguments
      '(#:phases
-       ;; build scripts not in root of archive
+       ;; The build scripts are not at the root of the archive.
        (modify-phases %standard-phases
          (add-after 'unpack 'pre-configure
            (lambda _