summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-25 17:40:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-25 19:07:10 +0300
commitdda785f66081871501236722f68c8eaa31103186 (patch)
tree8aad92e7b6ac222eacd45ac08fcb02fba7449213
parentc633b911cec5656c4a8054bc9276ec6cdc6be6cf (diff)
downloadguix-dda785f66081871501236722f68c8eaa31103186.tar.gz
gnu: go@1.4: Limit supported systems.
* gnu/packages/golang.scm (go@1.4)[supported-systems]: New field,
Limit supported systems to x86_64-linux, i686-linux and armhf-linux.
(go@1.9)[supported-systems]: New field.
-rw-r--r--gnu/packages/golang.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b1967b3f1a..f97f6f1711 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
 ;;; Copyright © 2016 Andy Wingo <wingo@igalia.com>
 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
@@ -198,6 +198,7 @@ programming language.  Designed primarily for systems programming, it is a
 compiled, statically typed language in the tradition of C and C++, with
 garbage collection, various safety features and in the style of communicating
 sequential processes (CSP) concurrent programming features added.")
+    (supported-systems '("x86_64-linux" "i686-linux" "armhf-linux"))
     (license license:bsd-3)))
 
 (define-public go-1.9
@@ -372,6 +373,7 @@ sequential processes (CSP) concurrent programming features added.")
                  (copy-recursively "../" output))))))))
     (native-inputs
      `(("go" ,go-1.4)
-       ,@(package-native-inputs go-1.4)))))
+       ,@(package-native-inputs go-1.4)))
+    (supported-systems %supported-systems)))
 
 (define-public go go-1.9)