summary refs log tree commit diff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2021-12-28 12:17:55 +0100
committerJelle Licht <jlicht@fsfe.org>2021-12-28 12:24:33 +0100
commite48b9d57129a9e7e680f5988b53ac87ebf946a39 (patch)
treeff12fc0bb682e7cb6298540d3d136d367909f91a
parent2c451db39aabc69bdbf186f412ee6e0b4e180ccb (diff)
downloadguix-e48b9d57129a9e7e680f5988b53ac87ebf946a39.tar.gz
gnu: emacs-el-patch: Update to 2.2.3-0.8ab8fb3.
* gnu/packages/emacs-xyz.scm (emacs-el-patch): Update to 2.2.3-0.8ab8fb3.
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7c8cce9065..36d42c4962 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25062,26 +25062,28 @@ all of your projects, then override or add variables on a per-project basis.")
     (license license:gpl3)))
 
 (define-public emacs-el-patch
-  (package
-    (name "emacs-el-patch")
-    (version "2.2.3")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/raxod502/el-patch")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "18djslz177q6q33y82zmg2v6n9236a76kiqfvxdk4vbqzjbq82f7"))))
-    (build-system emacs-build-system)
-    (home-page "https://github.com/raxod502/el-patch")
-    (synopsis "Future-proof your Emacs customizations")
-    (description "This package allows for an alternate definition of an Elisp
+  (let ((commit "8ab8fb3315ec9d3fd758929409ddf3151f464e80")
+        (revision "0"))
+    (package
+      (name "emacs-el-patch")
+      (version (git-version "2.2.3" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/raxod502/el-patch")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "197sxp4sscs0xlp67gbf5zh9ga521qvm9n7klpwljm1kf0jmm4vz"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/raxod502/el-patch")
+      (synopsis "Future-proof your Emacs customizations")
+      (description "This package allows for an alternate definition of an Elisp
 function to be specified and for any differences from the original definition
 to be examined using Ediff.")
-    (license license:expat)))
+      (license license:expat))))
 
 (define-public emacs-info-plus
   (let ((commit "29811edf7a71764ac343631facc00268d9483146")