summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 18:46:50 +0100
committerLeo Famulari <leo@famulari.name>2021-12-28 14:10:22 -0500
commitec3943de488188eae4d52805271434899606c86f (patch)
treeef728502421bcecd17562f4e0afd7605efc65cf8
parent74a977d7a7faa39cfa645efb92d325e22df22a54 (diff)
downloadguix-ec3943de488188eae4d52805271434899606c86f.tar.gz
gnu: Add rust-vcell-0.1.
* gnu/packages/crates-io.scm (rust-vcell-0.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e6e19d5c75..e188a0fed9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -61762,6 +61762,25 @@ a part of rav1e.")
     (description "This package provides anonymous structured values.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-vcell-0.1
+  (package
+    (name "rust-vcell")
+    (version "0.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "vcell" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "00n0ss2z3rh0ihig6d4w7xp72g58f7g1m6s5v4h3nc6jacdrqhvp"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t))
+    (home-page "https://github.com/japaric/vcell")
+    (synopsis "Cell with volatile read / write operations")
+    (description "This package provides a Cell structure with volatile read /
+write operations.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-vcpkg-0.2
   (package
     (name "rust-vcpkg")