summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-10-28 04:53:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-28 15:11:29 +0200
commitfe20121dc7b19d1804acc086707fa0c9463d3127 (patch)
tree9d8989f227588b7fe3700645496a6708ee4d610a
parent812cbd9321c8fdebf62afbc43aee106f91227072 (diff)
downloadguix-fe20121dc7b19d1804acc086707fa0c9463d3127.tar.gz
gnu: Add r-damefinder.
* gnu/packages/bioconductor.scm (r-damefinder): New variable.
-rw-r--r--gnu/packages/bioconductor.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 08eb33e4e0..9e463457f2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3036,6 +3036,47 @@ two-colour microarray experiments and for the statistical analysis of
 factorial microarray data.")
     (license license:gpl2+)))
 
+(define-public r-damefinder
+  (package
+    (name "r-damefinder")
+    (version "1.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "DAMEfinder" version))
+              (sha256
+               (base32
+                "123ra94bij0m45j2fzqr7fjipj4ld9kgk0kir1zfdbbd5h8h4mdf"))))
+    (properties `((upstream-name . "DAMEfinder")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biocgenerics
+           r-biostrings
+           r-bumphunter
+           r-cowplot
+           r-genomeinfodb
+           r-genomicalignments
+           r-genomicranges
+           r-ggplot2
+           r-iranges
+           r-limma
+           r-plyr
+           r-readr
+           r-reshape2
+           r-rsamtools
+           r-s4vectors
+           r-stringr
+           r-summarizedexperiment
+           r-variantannotation))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/DAMEfinder")
+    (synopsis "Differential allelicly methylated regions")
+    (description
+     "This package offers functionality for taking methtuple or Bismark
+outputs to calculate @acronym{ASM, Allele-Specific Methylation} scores and
+compute @acronym{DAMEs, Differential Allelicly MEthylated} regions.  It also
+offers nice visualization of methyl-circle plots.")
+    (license license:expat)))
+
 (define-public r-dearseq
   (package
     (name "r-dearseq")