summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-15 10:16:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-15 10:16:18 +0200
commit09b79f3bd5ad562feb00cb06bd1028711d01a879 (patch)
tree70d1311de6b2155b8526afef31f3ed7d1f2474b4
parent3e68f4004450b0ef3646d9512c23c3842884feca (diff)
downloadguix-09b79f3bd5ad562feb00cb06bd1028711d01a879.tar.gz
gnu: rust-heapsize-plugin-0.1: Don't hide package.
* gnu/packages/crates-io.scm (rust-heapsize-plugin-0.1)[arguments]: Skip
build. Add rust-heapsize-0.3 to cargo-inputs.
[properties]: Remove field.
-rw-r--r--gnu/packages/crates-io.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b5a91caf80..777ed35bad 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4154,12 +4154,14 @@ heap.")
          (base32
           "1i72isf699q9jl167g2kg4xd6h3cd05rc79zaph58aqjy0g0m9y9"))))
     (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-heapsize" ,rust-heapsize-0.3))))
     (home-page "https://github.com/servo/heapsize")
     (synopsis "Measure runtime size of an object on the heap")
     (description
      "This package automatically generates infrastructure for measuring the
 total runtime size of an object on the heap")
-    (properties `((hidden? . #t)))
     (license license:mpl2.0)))
 
 (define-public rust-hex-0.3