summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-06-15 10:35:18 -0700
committer宋文武 <iyzsong@member.fsf.org>2023-07-22 16:36:50 +0800
commit177c35a34444c07436d97530ea87050b46974fdf (patch)
tree4bfe75a6ecf8616744579b1ca4538d28fc8d683e
parente6403a56716c6fc150e001f93419077afdda1b76 (diff)
downloadguix-177c35a34444c07436d97530ea87050b46974fdf.tar.gz
gnu: mate-calc: Update to 1.26.0.
* gnu/packages/mate.scm (mate-calc): Update to 1.26.0.
[inputs]: Add mpc and mpfr.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/mate.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index e9dd6a4128..043ab34176 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -58,6 +58,7 @@
   #:use-module (gnu packages javascript)
   #:use-module (gnu packages libcanberra)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages messaging)
   #:use-module (gnu packages nss)
   #:use-module (gnu packages pkg-config)
@@ -1054,14 +1055,14 @@ sessions, panels, menus, file management, and preferences.")
 (define-public mate-calc
   (package
     (name "mate-calc")
-    (version "1.24.1")
+    (version "1.26.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://mate/" (version-major+minor version) "/"
                            "mate-calc-" version ".tar.xz"))
        (sha256
-        (base32 "0imdimq5d5rjq8mkjcrsd683a2bn9acmhc0lmvyw71y0040inbaw"))))
+        (base32 "0mddfh9ixhh60nfgx5kcprcl9liavwqyina11q3pnpfs3n02df3y"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
      (list gettext-minimal intltool pkg-config yelp-tools))
@@ -1071,6 +1072,8 @@ sessions, panels, menus, file management, and preferences.")
            gtk+
            libxml2
            libcanberra
+           mpc
+           mpfr
            pango))
     (home-page "https://mate-desktop.org/")
     (synopsis "Calculator for MATE")