summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-23 00:31:20 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:49 -0500
commit1df75a20b0a5024709299cb85d6831ce202596dc (patch)
tree5929ece57246359ca508e0161dea7ec14f8a82b7
parentf7f507b57724e44062f6a5d7e3a54176ae3e08da (diff)
downloadguix-1df75a20b0a5024709299cb85d6831ce202596dc.tar.gz
gnu: python-django-statici18n: Do not read PYTHONPATH.
* gnu/packages/django.scm (python-django-statici18n)
[phases]{check}: Do not read PYTHONPATH from environment.  Do not set
build/lib explicitly (the install site path is already in the Guix
PYTHONPATH).
-rw-r--r--gnu/packages/django.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index f25dd20b20..75a1121264 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -935,9 +935,7 @@ name is purely coincidental.")
      '(#:phases (modify-phases %standard-phases
                   (replace 'check
                     (lambda _
-                      (setenv "PYTHONPATH"
-                              (string-append "./tests/test_project:./build/lib:"
-                                             (getenv "PYTHONPATH")))
+                      (setenv "PYTHONPATH" "./tests/test_project")
                       (setenv "DJANGO_SETTINGS_MODULE" "project.settings")
                       (invoke "pytest" "-vv"))))))
     (native-inputs