summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-18 16:09:26 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-18 16:10:21 +0000
commit235adaeec682a0669335f06f194a7ef166d45c02 (patch)
tree85beed23df5d660c8e099677b76b39a15b1a9143
parent156843609c398e5976ae0d6577ec585b70165cf3 (diff)
downloadguix-235adaeec682a0669335f06f194a7ef166d45c02.tar.gz
gnu: python-xlwt: Use GUIX_PYTHONPATH instead of PYTHONPATH.
* gnu/packages/python-xyz.scm (python-xlwt)[arguments]: Update 'check phase to
set GUIX_PYTHONPATH instead of PYTHONPATH.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bc2e76b5be..b7c112a583 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10814,9 +10814,9 @@ Unicode-aware.  It is not intended as an end-user tool.")
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (setenv "PYTHONPATH"
+               (setenv "GUIX_PYTHONPATH"
                        (string-append (getcwd) "/build/lib:"
-                                      (getenv "PYTHONPATH")))
+                                      (getenv "GUIX_PYTHONPATH")))
                (invoke "nosetests" "-v")))))))
     (native-inputs
      `(("nose" ,python-nose)))