summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:50:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:29 +0200
commit23ea3e8a405b78cd2b376cd05bfeca222b3fa016 (patch)
treed578eb9014a54d7fbe0b5819c292ff28641a2c90
parentf4e823f17c5d23957160dd100187e41ae51b77b3 (diff)
downloadguix-23ea3e8a405b78cd2b376cd05bfeca222b3fa016.tar.gz
gnu: Add texlive-fntproof.
* gnu/packages/tex.scm (texlive-fntproof): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9fc2109abc..b26cec97fa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2581,6 +2581,29 @@ to apply to page dimensions.")
 subtraction, multiplication, division and rounding).")
     (license license:lppl1.2+)))
 
+(define-public texlive-fntproof
+  (package
+    (name "texlive-fntproof")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/fntproof/"
+                   "tex/generic/fntproof/")
+             (base32
+              "0pw0nw0dalnxqxpfgpw4pglngz3iff8sxxfdn89ygz46sv6427n5")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/fntproof")
+    (synopsis "Programmable font test pattern generator")
+    (description
+     "The package implements all the font testing commands of Knuth's
+@file{testfont.tex}, but arranges that information necessary for each command
+is supplied as arguments to that command, rather than prompted for.  This
+makes it possible to type all the tests in one command line, and easy to input
+the package in a file and to use the commands there.  A few additional
+commands supporting this last purpose are also made available.")
+    (license license:public-domain)))
+
 (define-public texlive-fontools
   (package
     (name "texlive-fontools")