summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-08 15:44:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-08 15:44:24 +0100
commit2d73db7a05d0f83232e44d6524450daf028ba4f6 (patch)
tree2e5af24703b335631758356f5ba3e297fb8aa2f2
parente6e82f629c86c8dc7a732fc886e896f88f4cea2d (diff)
downloadguix-2d73db7a05d0f83232e44d6524450daf028ba4f6.tar.gz
gnu: Add PatchELF.
* gnu/packages/patchelf.scm: New file.
* Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--gnu/packages/patchelf.scm47
2 files changed, 48 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c44c15932c..2a9702d8f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -117,6 +117,7 @@ MODULES =					\
   gnu/packages/oggvorbis.scm			\
   gnu/packages/openldap.scm			\
   gnu/packages/openssl.scm			\
+  gnu/packages/patchelf.scm			\
   gnu/packages/pcre.scm				\
   gnu/packages/pdf.scm				\
   gnu/packages/perl.scm				\
diff --git a/gnu/packages/patchelf.scm b/gnu/packages/patchelf.scm
new file mode 100644
index 0000000000..0a7ba5c261
--- /dev/null
+++ b/gnu/packages/patchelf.scm
@@ -0,0 +1,47 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages patchelf)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public patchelf
+  (package
+    (name "patchelf")
+    (version "0.6")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "http://nixos.org/releases/patchelf/patchelf-"
+                   version
+                   "/patchelf-"
+                   version
+                   ".tar.bz2"))
+             (sha256
+              (base32
+               "00bw29vdsscsili65wcb5ay0gvg1w0ljd00sb5xc6br8bylpyzpw"))))
+    (build-system gnu-build-system)
+    (home-page "http://nixos.org/patchelf.html")
+    (synopsis
+     "A small utility to modify the dynamic linker and RPATH of ELF executables")
+    (description
+     "PatchELF allows the ELF \"interpreter\" and RPATH of an ELF binary to be
+changed.")
+    (license gpl3+)))